Unofficialbmw.com Forum Index Unofficialbmw.com
The UnofficialBMW BB, answers for your BMW questions.
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

heater, interior fan doesnt work at all (update- FIXED )
Goto page Previous  1, 2
 
Post new topic   Reply to topic    Unofficialbmw.com Forum Index -> E30 - 3 Series Forum

Support Unofficialbmw.com :: Download Free Healthy Habits iPhone app!

View previous topic :: View next topic  
Author Message
smithpatrick



Joined: 05 Nov 2007
Posts: 44
Location: Southern New Jersey

PostPosted: Fri Oct 11, 2013 7:20 am    Post subject: no power to heater Reply with quote

just had this problem on a 1990 325i
I could not get power until I jumped out the k5 and k7. these find there ground comming from the starter cellinoid.
My ground signel had voltage present and was draining my battery also.
I had to replace the starter to correct the problem.
Try jumping out the uploader relays.
_________________
5 e30's 84, 87, 3 90's
4 Boxer motorcycles R75/5, 2 R60/6, and a R90/6
1995 e36 320i auto euro specs from canada, 98 323i auto
2001 e46 325i manual
Back to top
View user's profile Send private message Send e-mail
idanity



Joined: 21 May 2005
Posts: 3097
Location: N.W.U.S.A.

PostPosted: Sat Oct 12, 2013 5:02 pm    Post subject: Reply with quote

thanks.
and i do see a loose wire hanging by the starter...its black, so its likely ground.

also.
how exactly did you jump the relays, pix please...
_________________
..........
Back to top
View user's profile Send private message
dale



Joined: 22 Aug 1999
Posts: 3087
Location: Seattle, WA USA

PostPosted: Sun Oct 13, 2013 1:56 am    Post subject: Reply with quote

A standard Bosch Relay has 4 connections, these are labeled on the bottom of the relay, sometimes there is a diagram of how the relay works on the side:
Pin-30 12V Power In (supply)
Pin-87 12V Power Out (load, ie: what you're sending power to)

Pin-85 Ground
Pin-86 12V Signal In



ref site on how relays work:
http://www.mp3car.com/the-faq-emporium/117895-faq-relays-how-they-work-and-how-to-wire-it-up.html

==================
To answer your question "how do I jumper a relay", stick a wire between pins 30 and 87.

Careful though, if you go from 30 to 85, you'll ground that power supply and blow the fuse.

More info on relays
http://www.unofficialbmw.com/images/all_hella_relays.jpg

Dale
_________________
http://www.unofficialbmw.com
UnofficialBMW.com Webmaster
dale@unofficialbmw.com
sold in 2016
87 325 5spd eta
Back to top
View user's profile Send private message
dale



Joined: 22 Aug 1999
Posts: 3087
Location: Seattle, WA USA

PostPosted: Sun Oct 13, 2013 2:34 am    Post subject: Reply with quote

I've been having an issue on my '92 325ic with the fan only working on high speed #4 setting. I assumed it was the resistor pack gone bad ... except ... that every once in a while it would work fine, for a short while.
Then after restart, it would fail again.

Reading the comments here about the K7 unloader relay, I swapped it out for a different one.
Right now, the fan is working fine on all speeds, even after restart.
I'll let you know if it continues working over the next couple of days or if I end up swapping in a new resistor.

Dale
_________________
http://www.unofficialbmw.com
UnofficialBMW.com Webmaster
dale@unofficialbmw.com
sold in 2016
87 325 5spd eta
Back to top
View user's profile Send private message
idanity



Joined: 21 May 2005
Posts: 3097
Location: N.W.U.S.A.

PostPosted: Sun Oct 13, 2013 5:38 pm    Post subject: Reply with quote

Thank you everyone...
and.
GOOD NEWS... ! ... its *working



... note, * indicates its only working on the OFF, 2, 3, and 4 settings. ( looking into why the lowest setting doesnt work at a much later time...


so far, i have fixed the;
-dead wipers
-dead interior fan
-newer plugs (as the autolites (although new) were completely foulded)
- searched / found that the 323i engine is wired as a 325i (which needs timing to run correctly, and its not done yet),

all in all, i can finally drive this on a public road.... as i just didn't feel responsible enough to drive it without a defroster or wipers (especially here in seattle).

again, thanks yall
and i will post up pix soon enough... let me install a :
-alarm
-stereo
-seats
-steering wheel
-re-assemble the dash, or replace the dash as if i can find one.

Surprised
_________________
..........
Back to top
View user's profile Send private message
85-325e



Joined: 30 Jun 2002
Posts: 4711
Location: Southampton, NY

PostPosted: Sun Oct 13, 2013 6:07 pm    Post subject: Reply with quote

Dan...

OK, so the yellow wire is your speed 1, and it's tied, or has to be tied, to the recirculation button and a/c buttons. That's because if you push the recirculation button in, and don't have the fan switch on, the blower will still operate in first fan speed, and the A/C does the same I believe.

Look at the wiring diagram... anyway, if the low fan comes on with the recirculation button only, then you have to assume it's the blower switch on the console. if it doesn't come on with the recirculation switch, then I'd figure the yellow wasn't where it's supposed connected to the switch.

I wonder if the switch itself in a 323 is different in that car than the other 325 cars, part number wise and perhaps even pin/connector layout?

Anyway, try the test above...

Did you find the missing green wire?

Yellow is the 1st speed (Very Low),
Black is the 2nd speed (Low),
Green is the 3rd speed (Medium),
and Blue is the 4th speed (High speed).

The only other wire going to that switch on the dash is the hot coming in from the relay in the fuse box, and that's Green wire with a brown stripe with a Brown stripe.

According to the wiring diagram, the hot is coming from a relay, which may be one of the two you showed earlier in the thread.
_________________
Cosmo - 1985 BMW 325e, Single Owner, 235,000+ ORIGINAL miles and still going strong!

Back to top
View user's profile Send private message
idanity



Joined: 21 May 2005
Posts: 3097
Location: N.W.U.S.A.

PostPosted: Sun Oct 13, 2013 8:52 pm    Post subject: Reply with quote

great points.

from what ive found is.

the blower does spin with just the A/C button activated... so that could be my low setting.

and, rumor of the euro cars only have 3 speeds.
so, maybe my switch is a u.s. or euro version not matching with other stuff.

but in any case, this car will be an occasional street, drivers club, and sometimes a track car, and not going to be my dd... so, i am content with just off, 2, 3, and high... until i get a new dash, and pull it all out again (perhaps 2-8 months plan).

also
got all the error lights corrected, (found the washer fluid and coolant temp wires crossed)< and patched the oil low level light, CTS wires (were totally clipped)- repaired, fixed the intake housing, put most of the parts back together, and test-started... etc... so today was a success story Smile
_________________
..........
Back to top
View user's profile Send private message
85-325e



Joined: 30 Jun 2002
Posts: 4711
Location: Southampton, NY

PostPosted: Sun Oct 13, 2013 10:24 pm    Post subject: Reply with quote

Isn't it friggin' great when you have a productive day with your E30 like that???

Congrats Dan... You did good kid Wink! lol

I did do this search on RealOEM.com, (I have the ETK but this way you can see it online), and if you look carefully at the console panel, I believe you'll see only off and 3 settings:

http://realoem.com/bmw/showparts.do?model=1171&mospid=47260&btnr=64_0097&hg=64&fg=20

AND... Drum Roll Please.... This on the UK eBay:

http://www.ebay.co.uk/itm/Genuine-BMW-E30-Stereo-Surround-Heater-Panel-Switch-Part-No-64111385964-/251194202912?pt=UK_CarsParts_Vehicles_CarParts_SM&fits=Car+Make%3ABMW%7CPlat_Gen%3AE30&hash=item3a7c575b20

Check it out Dan! OBC is on the other side too! They ship worldwide but I don't know if shipping outside the UK is free... they do have a couple in stock... If I were you, I'd get it, install it, and sell the one that's in the car now... you'll break even and it'll be pretty darn cool & correct for the car! I wouldn't wait though... this is a neat opportunity and you should grab one before they're gone and you can't easily find another...
_________________
Cosmo - 1985 BMW 325e, Single Owner, 235,000+ ORIGINAL miles and still going strong!

Back to top
View user's profile Send private message
idanity



Joined: 21 May 2005
Posts: 3097
Location: N.W.U.S.A.

PostPosted: Thu Oct 17, 2013 12:06 am    Post subject: Reply with quote

if only money wasn't an issue.
but yes,
i probably will buy it if its up for sale in a few weeks.
_________________
..........
Back to top
View user's profile Send private message
dale



Joined: 22 Aug 1999
Posts: 3087
Location: Seattle, WA USA

PostPosted: Mon Oct 21, 2013 11:00 pm    Post subject: Reply with quote

Quote:
rumor of the euro cars only have 3 speeds


All '84 E30s have 3 speeds. In 85 or 86 they added the 4th speed.

Enis: does your '85 have 3 or 4 speeds on the fan?

Daniel: was it the K7 relay? Or a wiring issue? That caused the fan to not work?

Also, on Friday, when I looked last, my fan switch is still working on all speeds!

Dale
_________________
http://www.unofficialbmw.com
UnofficialBMW.com Webmaster
dale@unofficialbmw.com
sold in 2016
87 325 5spd eta
Back to top
View user's profile Send private message
85-325e



Joined: 30 Jun 2002
Posts: 4711
Location: Southampton, NY

PostPosted: Mon Oct 21, 2013 11:41 pm    Post subject: Reply with quote

Mine's a 4 speed fan... build date, June, 85

But, I believe, the 323 is a euro car, not a US build...
_________________
Cosmo - 1985 BMW 325e, Single Owner, 235,000+ ORIGINAL miles and still going strong!

Back to top
View user's profile Send private message
idanity



Joined: 21 May 2005
Posts: 3097
Location: N.W.U.S.A.

PostPosted: Tue Oct 22, 2013 1:33 am    Post subject: Reply with quote

it was the l7 relay.
after i jumped it, nothing happened, so i replaced it with one from my cabrio and it worked.

this after i replaced the motor too, and the interior relays that sit opposite of each other.
_________________
..........
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic    Unofficialbmw.com Forum Index -> E30 - 3 Series Forum All times are GMT - 5 Hours
Goto page Previous  1, 2
Page 2 of 2

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum



Powered by phpBB © 2001, 2005 phpBB Group