Unofficialbmw.com Forum Index Unofficialbmw.com
The UnofficialBMW BB, answers for your BMW questions.
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

Cluster question

 
Post new topic   Reply to topic    Unofficialbmw.com Forum Index -> E30 - 3 Series Forum

Support Unofficialbmw.com :: Download Free Healthy Habits iPhone app!

View previous topic :: View next topic  
Author Message
Pirate323i



Joined: 19 Aug 2004
Posts: 404
Location: Sydney, Australia

PostPosted: Mon Mar 28, 2011 6:28 pm    Post subject: Cluster question Reply with quote

Hi All!
I have just bought a another E30!
'89 Alpinweiss II coupe, with M52B25...
Whoo Hoo!
I helped a friend do this swap about three years ago. In January he moved overseas and sold the car to me (for a pittance Twisted Evil )
Anyway, I am slowly doing a few things to it to get it to MY standard Rolling Eyes
A question I have is:
Does anyone know where the signal for the L/100 gauge comes from? (I realise that your gauge is probably marked in miles per gallon or some such, in the US) I am talking about the gauge below the tacho...
when I start the car it swings all the way to the right and just stays there... this could be due to the cluster needing to be resoldered or could be due to the engine swap...
any information would be greatly appreciated!
Cheers.
_________________
Life is a voyage not a destination... So enjoy!

1989 318i M52B25 24v swap
1989 318i great little car
1983 323i same as picture only red! - Now gone...
1983 323i Written off by some fool running a red light... RIP.
Back to top
View user's profile Send private message

See all UnofficialBMW Ads
beejay



Joined: 18 Nov 2002
Posts: 1158
Location: Eastern, Pa

PostPosted: Mon Mar 28, 2011 9:01 pm    Post subject: Reply with quote

some else can chime in but I think the signal comes from the ECU.
I believe the SI board can make this weird as well, or as you mentioned bad solder. Or it's not compatible with the new ECU? Did it ever work after doing the swap?

Mine acts a little funny some times as well. It all started after I changed out the SI board with a rebuilt from programma.
I just kinda ignore it Very Happy

And congrats on the new toy. Have fun!
_________________
Bob
92 325ic gone Sad
14 BRZ ltd
05 Tundra SR5 TRD
01 VFR800fi - 03 DR650S - 83 CB1100F - 82 CB900F - 69 CB750
Back to top
View user's profile Send private message Send e-mail
Pirate323i



Joined: 19 Aug 2004
Posts: 404
Location: Sydney, Australia

PostPosted: Tue Mar 29, 2011 5:16 pm    Post subject: Reply with quote

Hey Beejay, thanks for the reply

Hmmm... if the signal is from the ECU then I might not get it to work, which is a shame.
I will have to go over the wiring diagram for the M52 ECU... it might not be hooked up at all. (my friend did the wiring... Rolling Eyes )

Any idea what that gauge is actually called?

I will probably have to ask on one of the 24v swap forums, but not sure what to call it! Mad
_________________
Life is a voyage not a destination... So enjoy!

1989 318i M52B25 24v swap
1989 318i great little car
1983 323i same as picture only red! - Now gone...
1983 323i Written off by some fool running a red light... RIP.
Back to top
View user's profile Send private message
85-325e



Joined: 30 Jun 2002
Posts: 4711
Location: Southampton, NY

PostPosted: Tue Mar 29, 2011 6:05 pm    Post subject: Reply with quote

The guage is fuel economy guage (meter), but I'm not exactly sure what BMW calls it.

I can't get into my garage right now as it snowed again and I haven't shoveled, but I know that it'll be mentioned in my manual which I have in the car. Maybe I can get in there tomorrow.

You know, I love that thing... and I'm pretty sure the SI board is the problem, because a year or so after I got the car, there was some recall and I was having problems with that guage. They replaced the SI board and it fixed it.
_________________
Cosmo - 1985 BMW 325e, Single Owner, 235,000+ ORIGINAL miles and still going strong!

Back to top
View user's profile Send private message
dale



Joined: 22 Aug 1999
Posts: 3085
Location: Seattle, WA USA

PostPosted: Sun Apr 03, 2011 2:42 am    Post subject: Reply with quote

Yah that signal comes from the Motronic ECU, and it might work

One good place to check is here at R3v
http://www.r3vlimited.com/board/forumdisplay.php?s=adb6ff9777a3d66078ef1ab46fcc4a2f&f=129

Here are the pin outs for the wiring, look for the Fuel Rate connection

http://www.akgmotorsport.com/e30convpins.html

30 side, pin #8 => M50/S50 side, pin #24

Chart showing pin arrangement when swapping e36 motor into e30 chassis.

==============================
From Pin # For To Pin #
'86-91 325 '92+ 325i, M3
1 Alternator charging 25
2 Not used
3 Not used
4 Coolant temperature sender 12
5 Oil pressure 23
6 Not used
7 Ignition switch 21
8 Fuel rate 24
9 Engine Speed 20
10 Not used
11 Diagnostic connector 19
12 Check engine light control 8
13 Fuel pump relay 13
14 Oil level fault set 14
15 Starter motor 15
16 Not used
17 Not used
18 Starter 18
19 Oil temp X6031 pin 10
20 Coolant temp 11
In some 86-87 models, Speed output is
C104 under glove box Engine speed output, BK/BU Tach 20

Nice diagram:

_________________
http://www.unofficialbmw.com
UnofficialBMW.com Webmaster
dale@unofficialbmw.com
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic    Unofficialbmw.com Forum Index -> E30 - 3 Series Forum All times are GMT - 5 Hours
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum



Powered by phpBB © 2001, 2005 phpBB Group