Unofficialbmw.com Forum Index Unofficialbmw.com
The UnofficialBMW BB, answers for your BMW questions.
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups   RegisterRegister 
 ProfileProfile   Log in to check your private messagesLog in to check your private messages   Log inLog in 

Turn signals suddenly quick flashing?..Fixed, was bulb

 
Post new topic   Reply to topic    Unofficialbmw.com Forum Index -> E30 - 3 Series Forum

Support Unofficialbmw.com :: Download Free Healthy Habits iPhone app!

View previous topic :: View next topic  
Author Message
tncean



Joined: 26 Feb 2005
Posts: 1652
Location: Chattanooga, Tn.

PostPosted: Wed Nov 24, 2010 11:54 am    Post subject: Turn signals suddenly quick flashing?..Fixed, was bulb Reply with quote

Signals, or bulbs, are working. Suggestions? Went from "normal" to quick flash.

Thanks.... And, happy feast day... I'll be at work.

tncean


Last edited by tncean on Sat Nov 27, 2010 1:51 pm; edited 1 time in total
Back to top
View user's profile Send private message
85-325e



Joined: 30 Jun 2002
Posts: 4710
Location: Southampton, NY

PostPosted: Wed Nov 24, 2010 6:01 pm    Post subject: Reply with quote

Is it the turn signal that's flashing fast, or the indicator on the cluster?
_________________
Cosmo - 1985 BMW 325e, Single Owner, 235,000+ ORIGINAL miles and still going strong!

Back to top
View user's profile Send private message
dale



Joined: 22 Aug 1999
Posts: 3085
Location: Seattle, WA USA

PostPosted: Thu Nov 25, 2010 12:54 am    Post subject: Reply with quote

Usually this is a change in resistance. If a bulb burns out, the resistance goes up for the circuit, and it blinks faster.
I believe corrosion on the bulb base or socket will have the same effect.
Try cleaning tail light turn signal bulb and front turn signal bulb contacts with some emery cloth to get rid of any corrosion.

Dale
_________________
http://www.unofficialbmw.com
UnofficialBMW.com Webmaster
dale@unofficialbmw.com
Back to top
View user's profile Send private message
tncean



Joined: 26 Feb 2005
Posts: 1652
Location: Chattanooga, Tn.

PostPosted: Fri Nov 26, 2010 10:36 pm    Post subject: Reply with quote

Well,... this started with a burned-out left rear "tail" light . When I pulled the left rear bulb assembly/cowl, the turn signal bulb got "caught" on the corner and the glass part of the turn signal lens got busted off. Replaced both bulbs with new units from Advance Auto... thought they were OEM Sylvanias... maybe they weren't?

Will follow up on this weekend.... the left turn signals are working, however, they flash at a "double-quick" rate.

Thanks!

tncean
Back to top
View user's profile Send private message
grantorino



Joined: 19 Sep 2010
Posts: 14
Location: stockton calif

PostPosted: Sat Nov 27, 2010 1:24 pm    Post subject: Reply with quote

The signal blinking too fast has a poor ground connection. So, check the front as well. Turn on the 4 way flasher and walk around the car, you should see an issue with a bulbs brightness, the dimmer one is where the fault is. Also the rear bulb cover/ cowl could be not fully seated in the multi wire plug on the body harness.
_________________
1986 325ES stick shift 137.000 miles
Back to top
View user's profile Send private message
tncean



Joined: 26 Feb 2005
Posts: 1652
Location: Chattanooga, Tn.

PostPosted: Sat Nov 27, 2010 1:49 pm    Post subject: Reply with quote

Fixed! T'was wrong bulb for the rear turn signal. The correct bulb # is Sylvania 7506. Thanks to Dale for a post some time back that listed the bulb numbers. I had a copy in my Bentley's, and, this time, chose the bulb myself.

Thanks! tncean
Back to top
View user's profile Send private message
85-325e



Joined: 30 Jun 2002
Posts: 4710
Location: Southampton, NY

PostPosted: Sat Nov 27, 2010 2:01 pm    Post subject: Reply with quote

Glad you got it fixed TN... In some respects, you've got to admire the engineers of these little cars to build something like rapid flashing into the car so you know something's wrong!

Well done M!

Cheers!
_________________
Cosmo - 1985 BMW 325e, Single Owner, 235,000+ ORIGINAL miles and still going strong!

Back to top
View user's profile Send private message
dale



Joined: 22 Aug 1999
Posts: 3085
Location: Seattle, WA USA

PostPosted: Mon Nov 29, 2010 5:44 pm    Post subject: Reply with quote

For anyone looking, that bulb reference post is here:
http://www.unofficialbmw.com/phpBB/viewtopic.php?p=187977
_________________
http://www.unofficialbmw.com
UnofficialBMW.com Webmaster
dale@unofficialbmw.com
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic    Unofficialbmw.com Forum Index -> E30 - 3 Series Forum All times are GMT - 5 Hours
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum



Powered by phpBB © 2001, 2005 phpBB Group